Wednesday, April 8, 2015

v1.4: Updates to Digitizing Application, Scaling for 2D morphometrics

StereoMorph version 1.4 just became available today on CRAN! I've made several improvements to the digitizing application based on user suggestions, particularly for 2D morphometrics.

New options in the 'Settings' panel in StereoMorph v1.4.
Users can now copy landmarks and curves from the current image to the next one, which makes it easier to digitize consecutive image frames from a video. Users can apply scaling directly in the app by digitizing points on a ruler or having the app automatically detect a checkerboard.

New 'Scaling' panel available in StereoMorph v1.4
Lastly, all of the shape and scaling data for an image can now be saved in a single text file and read into R using a single function (readShapes).

To demonstrate how to use the app, including these new features, I've made a new tutorial using different coffee mugs as an example. The tutorial is available as a PDF and you can download the example folder here (300KB).

The next updates will be to streamline 3D data collection using this same single file format. This should reduce the number of different folders that have to be created.

6 comments:

  1. Hi Aron,
    I am having a hard time visualizing the pictures in the browser.
    The app opens, but the pictures don't. I am using chrome.
    Any ideas on how to fix it?
    Thank you!

    ReplyDelete
    Replies
    1. Hi Silvia, thanks for the question and sorry you're having difficulties with the application. What file type of images are they? Note that if they are TIFFs you'll only be able to view them in Safari. Jpegs should show up in any major browser. Also are there any error messages printed to the R console?

      Delete
  2. Hi Aron,
    Thanks for responding so fast!
    I tried Chrome and Safari and my pics are JPG.
    I also tried converting them to TIFF and using safari. The Image just does not open/show.

    ReplyDelete
    Replies
    1. Hi Silvia,

      Thanks for trying that out. To fix this I'll need to reproduce the issue on my system. Can you send me the code that you are calling and some of the images that you are trying to load? You can send them to my e-mail at aarolsen at gmail.com. If you would prefer not to share your photos you could try loading some random internet JPGs instead and see if that works; then, if those doesn't work then you can just send me those random JPGs.

      Delete
  3. This comment has been removed by the author.

    ReplyDelete
  4. For anyone who arrives to this page and faces the same problem we figured out that it was because the image names had spaces in them. This was a problem in version 1.5 that should be fixed with version 1.6. If you are using an older version of StereoMorph (pre 1.6) just make sure that your image file names do not have spaces (e.g. use underscores, "_", instead)

    ReplyDelete